Home Downloads

Change Logs & Notes


Apache Haus Downloads

Apache binaries are built with the original source released by the Apache Software Foundation (unless noted) and have been compiled with Visual Studio 2015 (VC9) or Visual Studio 2017 (VC15) to obtain higher performance and better stability than the binaries built by the Apache Software Foundation


Binaries are built using the latest versions of the Apache Portable Runtime, OpenSSL and Zlib compression library. OpenSSL and Zlib are built using the optional assembly routines for added performance in the SSL and deflate modules.


After downloading and before you install, you should make sure that the file is intact and has not been tampered with. Use the SHA Checksums to verify the integrity.


JumpLinks
[ Apache 2.4 VC14 ] [ Apache 2.4 VC15 ]  
[ Apache 2.4 Modules VC14 ] [ Apache 2.4 Modules VC15 ]  
[ VC14 Redistributable ] [ VC15 Redistributable ]  

Apache 2.4 Server Binaries



Apache 2.4.x OpenSSL 1.1.1 VC15
Built using C sources from the ASF and OpenSSL on Visual Studio 2017 (VC15).
Note: VC15 binaries do not run on Windows XP or Server 2003
See readme_first.html file for details.


Apache 2.4.43 httpd-2.4.43-o111f-x86-vc15.zip 11.0 MB Download Locations
with OpenSSL 1.1.1f, brotli 1.0.7, nghttp 1.40.0, Zlib 1.2.10, PCRE 8.44, APR 1.7.0, APR-Util 1.6.1   0 httpd-2.4.43-o111f-x86-vc15   httpd-2.4.43-o111f-x86-vc15   
 

Apache 2.4.43 x64 httpd-2.4.43-o111f-x64-vc15.zip 12.1 MB Download Locations
with OpenSSL 1.1.1f, brotli 1.0.7, nghttp 1.40.0, Zlib 1.2.10, PCRE 8.44, APR 1.7.0, APR-Util 1.6.1   0 httpd-2.4.43-o111f-x64-vc15   httpd-2.4.43-o111f-x64-vc15   
 


Apache 2.4.x LibreSSL VC14
Built using C sources from the ASF and LibreSSL on Visual Studio 2015 (VC14).
Note: VC14 binaries do not run on Windows XP or Server 2003
See readme_first.html file for details.


Apache 2.4.43 httpd-2.4.43-lre302-x86-vc14.zip 10.4 MB Download Locations
with LibreSSL 3.0.2, brotli 1.0.7, nghttp 1.40.0, Zlib 1.2.10, PCRE 8.44, APR 1.7.0, APR-Util 1.6.1   0 httpd-2.4.43-lre302-x86-vc14   httpd-2.4.43-lre302-x86-vc14   
 

Apache 2.4.43 x64 httpd-2.4.43-lre302-x64-vc14.zip 11.3 MB Download Locations
with LibreSSL 3.0.2, brotli 1.0.7, nghttp 1.40.0, Zlib 1.2.10, PCRE 8.44, APR 1.7.0, APR-Util 1.6.1   0 httpd-2.4.43-lre302-x64-vc14   httpd-2.4.43-lre302-x64-vc14   
 

Top

Modules for Apache 2.4.x VC14

The modules below are built with Visual Studio C++ 2015 (VC14) for the 32 & 64 bit Apache 2.4.x VC14 versions and will NOT work with Apache 2.2.x.
Note: VC14 binaries do not run on Windows XP or Server 2003




Mod Antiloris 0.6.0 for Apache 2.4.x mod_antiloris-0.6.0-2.4.x-vc14-x86.zip 7.4 KB Download Locations
Mod_Antiloris 0.6.0 is a module to mitigate the Slowloris attack and modified to mitigate other similar attacks against an Apache web server.   0 mod_antiloris-0.6.0-2.4.x-vc14-x86   mod_antiloris-0.6.0-2.4.x-vc14-x86   
 

Mod Antiloris 0.6.0 for Apache 2.4.x x64 mod_antiloris-0.6.0-2.4.x-vc14-x64.zip 7.7 KB Download Locations
Mod_Antiloris 0.6.0 is a module to mitigate the Slowloris attack and modified to mitigate other similar attacks against an Apache web server.   0 mod_antiloris-0.6.0-2.4.x-vc14-x64   mod_antiloris-0.6.0-2.4.x-vc14-x64   
 

Mod Auth NTLM for Apache 2.4.x mod_authn_ntml-1.0.8-2.4.x-x86-vc14.zip 47.2 KB Download Locations
SSPI NTLM based authentication module for Apache   0 mod_authn_ntml-1.0.8-2.4.x-x86-vc14   mod_authn_ntml-1.0.8-2.4.x-x86-vc14   
 

Mod Auth NTLM for Apache 2.4.x x64 mod_authn_ntml-1.0.8-2.4.x-x64-vc14.zip 53.4 KB Download Locations
SSPI NTLM based authentication module for Apache   0 mod_authn_ntml-1.0.8-2.4.x-x64-vc14   mod_authn_ntml-1.0.8-2.4.x-x64-vc14   
 

Mod Bandwidth for Apache 2.4.x mod_bw-0.92-2.4.x-x86-vc14.zip 28.4 KB Download Locations
Bandwidth limiting module for Apache 2.4   0 mod_bw-0.92-2.4.x-x86-vc14   mod_bw-0.92-2.4.x-x86-vc14   
 

Mod Bandwidth for Apache 2.4.x x64 mod_bw-0.92-2.4.x-x64-vc14.zip 29.3 KB Download Locations
Bandwidth limiting module for Apache 2.4   0 mod_bw-0.92-2.4.x-x64-vc14   mod_bw-0.92-2.4.x-x64-vc14   
 

Mod FCGID 2.3.9a for Apache 2.4.x mod_fcgid-2.3.9a-2.4.x-x86-vc14.zip 65.9 KB Download Locations
A binary compatibility alternative to Apache module mod_fastcgi for Apache 2.4.x   0 mod_fcgid-2.3.9a-2.4.x-x86-vc14   mod_fcgid-2.3.9a-2.4.x-x86-vc14   
 

Mod FCGID 2.3.9a for Apache 2.4.x x64 mod_fcgid-2.3.9a-2.4.x-x64-vc14.zip 70.1 KB Download Locations
A binary compatibility alternative to Apache module mod_fastcgi for Apache 2.4.x   0 mod_fcgid-2.3.9a-2.4.x-x64-vc14   mod_fcgid-2.3.9a-2.4.x-x64-vc14   
 

Mod Limit IP Connection for Apache 2.4.x mod_limitipconn-0.24-2.4.x-x86-vc14.zip 16.1 KB Download Locations
Apache 2.4.x module to limit the maximum number of simultaneous connections per IP address. Allows inclusion and exclusion of files based on MIME type.   0 mod_limitipconn-0.24-2.4.x-x86-vc14   mod_limitipconn-0.24-2.4.x-x86-vc14   
 

Mod Limit IP Connection for Apache 2.4.x x64 mod_limitipconn-0.24-2.4.x-x64-vc14.zip 16.6 KB Download Locations
Apache 2.4.x module to limit the maximum number of simultaneous connections per IP address. Allows inclusion and exclusion of files based on MIME type.   0 mod_limitipconn-0.24-2.4.x-x64-vc14   mod_limitipconn-0.24-2.4.x-x64-vc14   
 

Mod Log Rotate for Apache 2.4.x mod_log_rotate-1.0-2.4.x-x86-vc14.zip 8.3 KB Download Locations
Adds RotateLogs and supporting directives that allow logs to be rotated by the server without having to pipe them through rotatelogs   0 mod_log_rotate-1.0-2.4.x-x86-vc14   mod_log_rotate-1.0-2.4.x-x86-vc14   
 

Mod Log Rotate for Apache 2.4.x x64 mod_log_rotate-1.0-2.4.x-x64-vc14.zip 9.3 KB Download Locations
Adds RotateLogs and supporting directives that allow logs to be rotated by the server without having to pipe them through rotatelogs   0 mod_log_rotate-1.0-2.4.x-x64-vc14   mod_log_rotate-1.0-2.4.x-x64-vc14   
 

Mod MaxmindDB for Apache 2.4.x mod_maxminddb-1.1.0.121-x86-vc14.zip 1,212.3 KB Download Locations
As it's predecessor mod_geoip, mod_maxminddb is a geo-location reference module for obtaining a visitor geographic location from their IP.   0 mod_maxminddb-1.1.0.121-x86-vc14   mod_maxminddb-1.1.0.121-x86-vc14   
 

Mod MaxmindDB for Apache 2.4.x x64 mod_maxminddb-1.1.0.121-x64-vc14.zip 1,214.0 KB Download Locations
As it's predecessor mod_geoip, mod_maxminddb is a geo-location reference module for obtaining a visitor geographic location from their IP.   0 mod_maxminddb-1.1.0.121-x64-vc14   mod_maxminddb-1.1.0.121-x64-vc14   
 

Mod Security Version 2.9.3 for Apache 2.4.x mod_security2-2.9.3-2.4.x-x86-vc14.zip 1,194.1 KB Download Locations
Mod Security is a web application firewall for Apache, this module is for Apache 2.x   0 mod_security2-2.9.3-2.4.x-x86-vc14   mod_security2-2.9.3-2.4.x-x86-vc14   
 

Mod Security Version 2.9.3 for Apache 2.4.x 64 mod_security2-2.9.3-2.4.x-x64-vc14.zip 1,391.7 KB Download Locations
Mod Security is a web application firewall for Apache, this module is for Apache 2.x   0 mod_security2-2.9.3-2.4.x-x64-vc14   mod_security2-2.9.3-2.4.x-x64-vc14   
 

Top

Modules for Apache 2.4.x VC15

The modules below are built with Visual Studio C++ 2017 (VC15) for the 32 & 64 bit Apache 2.4.x VC15 versions and will NOT work with Apache 2.2.x.
Note: VC15 binaries do not run on Windows XP or Server 2003




Mod Antiloris 0.6.0 for Apache 2.4.x mod_antiloris-0.6.0-2.4.x-vc15-x86.zip 7.1 KB Download Locations
Mod_Antiloris 0.6.0 is a module to mitigate the Slowloris attack and modified to mitigate other similar attacks against an Apache web server.   0 mod_antiloris-0.6.0-2.4.x-vc15-x86   mod_antiloris-0.6.0-2.4.x-vc15-x86   
 

Mod Antiloris 0.6.0 for Apache 2.4.x x64 mod_antiloris-0.6.0-2.4.x-vc15-x64.zip 7.4 KB Download Locations
Mod_Antiloris 0.6.0 is a module to mitigate the Slowloris attack and modified to mitigate other similar attacks against an Apache web server.   0 mod_antiloris-0.6.0-2.4.x-vc15-x64   mod_antiloris-0.6.0-2.4.x-vc15-x64   
 

Mod Auth NTLM for Apache 2.4.x mod_authn_ntml-1.0-2.4.x-x86-vc15.zip 47.8 KB Download Locations
SSPI NTLM based authentication module for Apache   0 mod_authn_ntml-1.0-2.4.x-x86-vc15   mod_authn_ntml-1.0-2.4.x-x86-vc15   
 

Mod Auth NTLM for Apache 2.4.x x64 mod_authn_ntml-1.0-2.4.x-x64-vc15.zip 55.1 KB Download Locations
SSPI NTLM based authentication module for Apache   0 mod_authn_ntml-1.0-2.4.x-x64-vc15   mod_authn_ntml-1.0-2.4.x-x64-vc15   
 

Mod Bandwidth for Apache 2.4.x mod_bw-0.92-2.4.x-x86-vc15.zip 27.7 KB Download Locations
Bandwidth limiting module for Apache 2.4   0 mod_bw-0.92-2.4.x-x86-vc15   mod_bw-0.92-2.4.x-x86-vc15   
 

Mod Bandwidth for Apache 2.4.x x64 mod_bw-0.92-2.4.x-x64-vc15.zip 28.5 KB Download Locations
Bandwidth limiting module for Apache 2.4   0 mod_bw-0.92-2.4.x-x64-vc15   mod_bw-0.92-2.4.x-x64-vc15   
 

Mod FCGID 2.3.9a for Apache 2.4.x mod_fcgid-2.3.9a-2.4.x-x86-vc15.zip 64.5 KB Download Locations
A binary compatibility alternative to Apache module mod_fastcgi for Apache 2.4.x   0 mod_fcgid-2.3.9a-2.4.x-x86-vc15   mod_fcgid-2.3.9a-2.4.x-x86-vc15   
 

Mod FCGID 2.3.9a for Apache 2.4.x x64 mod_fcgid-2.3.9a-2.4.x-x64-vc15.zip 68.6 KB Download Locations
A binary compatibility alternative to Apache module mod_fastcgi for Apache 2.4.x   0 mod_fcgid-2.3.9a-2.4.x-x64-vc15   mod_fcgid-2.3.9a-2.4.x-x64-vc15   
 

Mod Limit IP Connection for Apache 2.4.x mod_limitipconn-0.24-2.4.x-x86-vc15.zip 15.7 KB Download Locations
Apache 2.4.x module to limit the maximum number of simultaneous connections per IP address. Allows inclusion and exclusion of files based on MIME type.   0 mod_limitipconn-0.24-2.4.x-x86-vc15   mod_limitipconn-0.24-2.4.x-x86-vc15   
 

Mod Limit IP Connection for Apache 2.4.x x64 mod_limitipconn-0.24-2.4.x-x64-vc15.zip 16.1 KB Download Locations
Apache 2.4.x module to limit the maximum number of simultaneous connections per IP address. Allows inclusion and exclusion of files based on MIME type.   0 mod_limitipconn-0.24-2.4.x-x64-vc15   mod_limitipconn-0.24-2.4.x-x64-vc15   
 

Mod Log Rotate for Apache 2.4.x mod_log_rotate-1.0-2.4.x-x86-vc15.zip 8.0 KB Download Locations
Adds RotateLogs and supporting directives that allow logs to be rotated by the server without having to pipe them through rotatelogs   0 mod_log_rotate-1.0-2.4.x-x86-vc15   mod_log_rotate-1.0-2.4.x-x86-vc15   
 

Mod Log Rotate for Apache 2.4.x x64 mod_log_rotate-1.0-2.4.x-x64-vc15.zip 8.9 KB Download Locations
Adds RotateLogs and supporting directives that allow logs to be rotated by the server without having to pipe them through rotatelogs   0 mod_log_rotate-1.0-2.4.x-x64-vc15   mod_log_rotate-1.0-2.4.x-x64-vc15   
 

Mod MaxmindDB for Apache 2.4.x mod_maxminddb-1.0.1.132-x86-vc15.zip 1,634.8 KB Download Locations
As it's predecessor mod_geoip, mod_maxminddb is a geo-location reference module for obtaining a visitor geographic location from their IP.   0 mod_maxminddb-1.0.1.132-x86-vc15   mod_maxminddb-1.0.1.132-x86-vc15   
 

Mod MaxmindDB for Apache 2.4.x x64 mod_maxminddb-1.0.1.132-x64-vc15.zip 1,636.3 KB Download Locations
As it's predecessor mod_geoip, mod_maxminddb is a geo-location reference module for obtaining a visitor geographic location from their IP.   0 mod_maxminddb-1.0.1.132-x64-vc15   mod_maxminddb-1.0.1.132-x64-vc15   
 

Mod Security Version 2.9.3 for Apache 2.4.x mod_security2-2.9.3-2.4.x-x86.zip 1,317.7 KB Download Locations
Mod Security is a web application firewall for Apache, this module is for Apache 2.x   0 mod_security2-2.9.3-2.4.x-x86   mod_security2-2.9.3-2.4.x-x86   
 

Mod Security Version 2.9.3 for Apache 2.4.x 64 mod_security2-2.9.3-2.4.x-x64.zip 1,535.6 KB Download Locations
Mod Security is a web application firewall for Apache, this module is for Apache 2.x   0 mod_security2-2.9.3-2.4.x-x64   mod_security2-2.9.3-2.4.x-x64   
 

Top

Visual Studio Redistributable Packages



Microsoft Visual C++ 2015 Redistributable
Microsoft Visual C++ 2015 Redistributable Packages to be used for our VC14 builds


Microsoft Visual C++ 2015 Redistributable Package (X86 & x64) Microsoft Download 13.1 - 13.9 MB Direct Download Link
The Microsoft Visual C++ 2015 Redistributable Package (X86 & x64) installs runtime components of Visual C++ Libraries required to run applications developed with Visual C++ on a computer that does not have Visual C++ 2015 installed.    
 


Microsoft Visual C++ 2017 Redistributable
Microsoft Visual C++ 2017 Redistributable Packages to be used for our VC15 builds


Microsoft Visual C++ 2017 Redistributable Package (X86) Microsoft Download 14 MB Direct Download Link
Microsoft Visual C++ 2017 Redistributable Package (X64) Microsoft Download 14.6 MB Direct Download Link
The Microsoft Visual C++ 2017 Redistributable Package (X86 & x64) installs runtime components of Visual C++ Libraries required to run applications developed with Visual C++ on a computer that does not have Visual C++ 2017 installed.    
 

Top